Incidents added from:
Write-up published
Resolved
The issue has been fully resolved. Everything should be back to normal.
Identified
We have identified an issue that is causing degraded sandbox create times and can lead to the operations timing out in some cases.
The team is working hard on resolving the issue; we apologize for the inconvenience.