Back to overview
Degraded

EU region degradation

Apr 21, 2026 at 9:18am UTC
Affected services
Sandbox Network Traffic
Sandbox Pause/Resume/Create
Template Builds

Resolved
Apr 21, 2026 at 10:30am UTC

The issue has been resolved

Created
Apr 21, 2026 at 9:18am UTC

We are aware of an issue affecting our EU customers. The team is working on it.